Skip to end of metadata
Go to start of metadata

Overview

Prior to starting the Men & Mice Management Console, make sure that you have installed and started the other Men & Mice Suite modules, as required. Refer to the Installation Guide for other components.
The Men & Mice Management Console boasts a very intuitive interface. It is the central organizational tool of the Men & Mice Suite and provides all the tools you need to oversee the management of your DNS and DHCP servers.

The Men & Mice Management Console is the GUI client of a client/server application that allows you to administer local DNS/DHCP servers and IP Addresses. Specifically, it provides a simple graphical user interface that allows you to manage your domain names and IP Addresses.

From the Management Console, you can simultaneously manage DHCP/DNS servers on different platforms. 

Icon
Be aware that you will only be able to view the servers to which you have access. The administrator user has access to all servers.

Launching the Men & Mice Suite

When logging into the Men & Mice Management Console, you have the option to choose "Single Sign-on." This allows those users working on a Microsoft Network with Active Directory to sign on one time only to access all your resources.

Icon

If you are the system administrator, you can choose whether to enable this option. In the Management Console, move to the menu bar and select Tools, System Settings. In the System settings dialog box, click the General tab. Check in the checkbox next to Allow Single Sign-on to enable this option. Then click OK.


To start the Management Console, do the following:

  1. Locate and launch the Men & Mice Management Console. The Men & Mice Management Console login dialog box displays.
     
  2. In the Server name field, type the name or IP Address (IPv4 or IPv6) of the workstation on which Men & Mice Central is running. This is only required the first time you log in. After a successful connection, this field will be pre-filled with the server name you enter.
  3. In the User and Password fields, type the applicable information. The default value for both fields is administrator.
  4. If you want to enable Single Sign-on, click in the checkbox.
  5. Click the Connect button. If this is the first time any user logs into this particular Men & Mice Central, the First Use Wizard launches. Otherwise, within a few moments, the Men & Mice Management Console will start, and the Manager window will display.

 

First Use Wizard

The First Use Wizard has been improved greatly in version 6.8. It is able to discover

  • DNS Servers
  • DHCP Server
  • AD Subnets

When connecting the Management Console to a newly installed instance of Men & Mice Central or if this is the first time logging in, you will be presented by the First Use Wizard. 

  1. Log in using the default credentials (administrator:administrator). You will be presented by the figure below. Click 'Next' after having specified a new password for administrator user.
  2. Complete each screen as you move through the wizard.
  3. The wizard will finish after the user clicks the 'Finish' button and afterwords the changes will be applied. 

GUI Interface

When the Management Console is started up, the Manager Window displays in the center. This window is the heart of the Men & Mice Management Console, providing a single interface with nearly every feature in the Men & Mice Suite. 


This window consists of two main areas: the Object Browser and the Detail View.

Object Browser

The Object Browser displays on the left side of the Manager window and contains categories of objects that can be created, modified, and deleted.

  • DNS Zones. Selecting the DNS Zones object will cause the Detail View to display all DNS zones configured in the system and accessible to the current user. This category is accessible with a valid DNS Module License Key.
  • DNS Servers. Selecting the DNS Servers category will cause the Detail View to display all DNS servers managed by the system and accessible to the current user. If a DNS server is not reachable, its icon is shown with an exclamation mark. If the DNS Servers category is expanded, the same list of servers will show as sub-categories to the DNS Servers category. Selecting a server subcategory will cause the Detail View to display the zones managed by that server and accessible to the current user. This category is accessible with a valid DNS Module License Key.
  • DNS Views. The DNS Views category allows you to see zones on DNS servers that are configured with multiple views. If no views are configured on any server, this category will not appear. The Views feature of the BIND name server allows one server to return different data to different clients; each view has its own separate list of zones, often with the same names. This category behaves similarly to the DNS Servers category.
  • IP Address Ranges. Selecting the IP Address Ranges category will cause the Detail View to display all IP Address Ranges configured in the system and accessible to the current user. This category is accessible with a valid IP Address Management Module License Key.
  • DHCP Scopes. Selecting the DHCP Scopes category will cause the Detail View to display all DHCP scopes configured in the system and accessible to the current user. This category is accessible with a valid DHCP Module License Key.
  • DHCP Servers. Selecting the DHCP Servers category causes the Detail View to display all DHCP servers managed by the system and accessible to the current user. If a DHCP server is not reachable, its icon is shown with an exclamation mark. If the DHCP Servers category is expanded, the same list of servers will show as sub-categories to the DHCP Servers category. Selecting a server subcategory causes the Detail View to display the scopes managed by that server and accessible to the current user. This category is accessible with a valid DHCP Module License Key.
  • AD Sites. This category is only displayed if you have enabled AD Sites and Subnets integration. Selecting this category will show all AD sites that have been selected for integration in the Men & Mice Suite.

Detail View

Note that a new feature in version 7.2 is that the windows are now 'docked' and therefore they open up in a tab instead of a window.

The Detail View displays on the right side of the Manager window and displays the contents of the selected category in the Object Browser. While in this view, you can do the following:

  • Sort and filter to allow a more concise view of the contents. Refer to  Quick Filter .
  • Display a shortcut or "context" menu that gives access to other options. Right-click to view this shortcut menu.
  • Open an object by simply double-clicking. This opens either a property window (such as in the case of DNS/DHCP Servers), or brings you to a new view of the data contained within the object (such as in the case of DNS Zones, DHCP Zones, and IP Address Ranges).
  • Reorder the columns. Click on the column you want to move and, while holding down the mouse key, drag the column to the new position.
  • Display or hide columns. Right-click on a column header. All the column names shown with a checkmark are currently displayed. To hide a column, click on the name to remove the checkmark. To display a hidden column, repeat the process. Reset all makes all columns display without having to unhide them individually.

Sorting Records

When viewing information in the Object List – be it DNS zones, Servers, Views, IP Address Ranges, or Scopes – you can instantly sort the displayed information by clicking on the header of any column shown in that view. For instance, click on the Name header once to sort the displayed objects alphabetically (A-Z) by name. Clicking on the Name header again will resort the list in reverse alphabetic order (Z-A). This can be done with any column of data, including Servers, Addresses, Utilization percentages, etc. 
When sorting zone names alphabetically, reverse zones will appear at the bottom of the list (after Z), or at the top of the list when sorted in reverse alphabetic order.

Menu Bars

The Menu Bar in the Men & Mice Management Console provides access to nearly all of the program's functionality.

Icon
  • You must have sufficient access privileges in order to use some of the menu items discussed below.
  • Not every menu option is listed below. Some are detailed in their respective sections. Some of the options discussed below are global across the whole application (e.g., Cut, Copy, and Paste).

File Menu

  • Save. Saves any changes that have been made in the currently active window. This is only available when a zone has been edited and there is some new data to be saved.
  • Change Password. Use this command to change your login password to the Management Console. Your current password is required in order to change to a new one.
  • Page Setup. Opens the Print Setup dialog box, from which you can choose the default printer, paper, page orientation, and other properties to be used when printing from Management Console.
  • Print. Opens the Print dialog box and allows you to print the contents of the currently selected Zone window. This command is only available when a Zone window is open.
  • Exit. Closes the Management Console window.

Edit Menu

The commands available from the Edit menu vary, depending on what is currently selected in the Management Console. When working in the Manager window the following functions are offered:

  • Undo. Reverses the last edits that you made, in the reverse-order that you made them.
  • Redo. Reverses the effects of the last Undo command.
  • Cut. Removes the currently selected item(s) and stores them in the Windows clipboard.
  • Copy. Makes a copy of the currently selected item(s) and places it into the Windows clipboard.
  • Paste. Copies the contents of the clipboard at the location of the insertion point.
  • Paste Custom Properties. Allows pasting of custom property contents into multiple objects. To use this command, select one object and choose Copy. Then select the objects whose custom properties you want to populate and choose Paste Properties. This will open a dialog box where you can choose which custom properties you want to paste.
  • Clear. Deletes the currently selected text or record.
  • Select All. This command selects all of the objects (e.g., zones, servers, scopes, IP Address ranges).
  • Find. This command initiates a new search.
  • Find Next. This command repeats the last search you performed. For example, if the last search was for A, this automatically locates the next occurrence of A in the object list.
  • Save Filter/Delete Filter. It is possible to save/delete filters for various object types. Saved filters appear in the list on the left hand side of the Manager Window and in the Create Zone dialog box. Filters can be local or global in scope. Filters created by the Administrator are global and visible to all users. Filters created by any other user are visible only to that user.
  • Preferences. Opens the Options dialog box where you can make default selections for various Management Console functions.

When working with a zone, the Edit menu changes and includes additional functions.

  • Enable Record. Makes the currently selected record(s) active in the zone. Use this command to re-enable a zone that has been disabled. All records are active by default unless they have been manually disabled. You cannot enable records in dynamic zones.
  • Disable Record. Makes the currently selected record inactive. When a record is disabled, it is ignored in the zone. You cannot disable records in dynamic zones.
  • Insert Record. Opens a popup menu that lets you specify the type of record you want to create. To insert A, CNAME, MX, NS, or PTR records, choose the corresponding option from the menu. The new record is created directly below the currently selected record or field. For other types of records, select Insert Record. This creates a new blank row above the currently selected record or field.
  • Duplicate Record. Creates a copy of the selected record(s). The new records appear directly underneath the last record being duplicated.
  • Delete Record. Deletes the entire record from the zone. Unlike the Clear command, the entire record does not need to be selected for this command to work. It will delete the entire record in which the cursor is currently located.
  • Show TTL. This menu command can be toggled on and off by selecting it repeatedly. This option is enabled by default. If you disable this option, the TTL column will not be displayed in the zone window. This command is only available when a zone window is open and active.
  • Show Comment. This menu command can be toggled on and off by selecting it repeatedly. This option is enabled by default. If you disable this option, the Comment column will not be displayed in the zone windows. This command is only available when a Zone window is open and active. This command can only be used for static zones.

Query Menu

  • Lease History. This function can be enabled through System Settings, Logging. When enabled you can search the DHCP lease history and if desired, export the search results to a file.
  • Object History. Allows you to query the history throughout the system for all objects or a specific object. Refer to  Object Change History  for details. You can search all objects or, using the Only show objects of type drop-down list, you can select which object type to search. You can only search all object types or one selected object type.
  • Men & Mice Suite Log. Displays log messages for the Men & Mice Suite.
  • Search and Update Wizard. Launches the Search and Update Wizard, a utility that allows you to find, create, modify, or delete records in multiple zones and DHCP Scopes using a single action. Click Next> and follow the instructions onscreen to specify the type of records you want to search, the action you want to perform (e.g., create, replace, delete, edit), etc.
  • User Activity. Users with user administrative privileges can see this menu item. Selecting this menu item displays a window that shows a list of all users including the user name, authentication type, login status, and last login time.

Window Menu

  • Cascade. Aligns all currently open windows inside the Console window so that they overlap, showing only their title bars. This allows you to access all currently open windows.
  • Show Progress. This window shows the progress of operation that can take some time, such as opening and saving large zones. When an operation is in progress (and displayed in the progress window) it can be cancelled by clicking in the progress window and choosing Cancel.
  • Show Console. Displays errors that may occur during various operations.
  • Show Manager Window. Displays the Manager Window. Use this function in the event you inadvertently close the Manager window.
  • Revert to Standard Layout. Returns the program to its standard view, with the Management Console open and the main window displayed on top of any other open windows. Other windows are not affected by this command. Also, shows the progress window if the window is hidden.
  • Active Window List. At the bottom of the Window menu, there will be a list of every window currently open in the Management Console. You can instantly give a window the focus (i.e., bring it to the top) by selecting it from this list.

Help Menu

  • Help. Launches the on-line help features of the Men & Mice Suite.
  • About Men and Mice Management Console. Opens the About window, which contains the full version number of the Men & Mice Management Console that you are running.

Toolbars

The toolbar, which runs along the top of the Object Section and Object List, provides fast access to commonly performed operations. The function of any given button is always in the context of the currently selected object. Some buttons will not be available (i.e., greyed out) when certain objects are selected.

BUTTON

NAME

DESCRIPTION

Create

Lets you create a zone, add a name server, a DHCP scope, or a DHCP server based on the currently selected object.

Delete

Lets you delete a zone, a name server, a DHCP scope, or a DHCP server; based on the currently selected object.

Options

Display the options dialog box for the currently selected object, if applicable (e.g., Zone options, Server options, etc.).

Server Info

Displays a window that provides general information about the selected server—e.g., server type, IP Address, OS, number of zones, number of requests sent/received, etc. Refer to DNS Servers—Server Information .

Server Log

Displays the Server Log window that shows the DNS log of that server. Refer to DNS Servers—Server Log .

History

Opens the History window and displays a log of all changes that have been made to the selected object, including the date and time of the change, the name of the user who made it, the actions performed, and any comments entered by the user. Refer to Management Console—Object Change History .

Zone Wizard

Launches the Zone Wizard, which helps you create the desired type of zone by prompting you with a series of questions. Refer to DNS Zones—Zone Migration Wizard .

Views

When selected, toggles between hierarchical and flat view for the IP Address range.

N/A

Quick Filter

This text field lets you instantly filter out objects that you do not want to display. For example, if you type "ex" in the field, only objects that contain "ex" somewhere in their name are displayed in the Object List. When you clear the contents from this field, all available objects are again displayed. Refer to Quick Filter .

Zone Toolbar

BUTTON

NAME

DESCRIPTION

Save

Saves the information as entered in the main zone information window.

Print

Prints the zone information.

Find

Opens the Find Zone dialog box in which you enter criterion to locate specific information for this zone. Refer to DNS Zones—Search .

Options

Opens the Zone Options dialog box. Refer to the DNS Zones—Zone Options .

History

Displays the history for the selected zone. Refer to the DNS Zones—View History .

Wizard

Launches the Record Creation Wizard. Refer to DNS Resource Records.

 

Zone Controls

Only available for static zones on BIND Opens the Zone Controls dialog box. Refer to the DNS Zones—Zone Controls .

Analyze

Analyzes the contents of the zone. Refer to DNS Zones—Zone Analysis .

IP Address Range Toolbar

BUTTON

NAME

DESCRIPTION

Delete

Removes the currently selected host. Refer to IP Address Management.

Edit

Opens the IP Address dialog box in which you can edit details for the IP Address. Refer to IP Address Management .

Claim/Release

Use this feature to prevent accidental assignment of a reserved address without creating a DNS entry for it. The workflow is as follows:

  • A user with "edit data" privileges can select one or more addresses that have no associated A record(s) and choose "Claim" from the menu. Going forward, no one can create A records for the address(es) through the zone window (neither auto-assign nor manually assign).
  • A user can select one or more claimed addresses and select "Release." These addresses are then restored to their previous state.
  • A user can edit a Claimed record through the IPAM module. When the user opens a IP Address details window for a claimed address, a dialog prompts, "This address has been claimed. Are you sure you want to edit it?" Yes/No? When Save is selected in the IP Address details window, one of two things happens: (1) If the user only entered non-DNS data (custom properties, MAC address, name), the "claimed" flag says in place. (2) If the user entered one or more DNS hosts for the IP Address, the "claimed" flag is cleared.

Next Free Address in Range

Finds the first IP Address in the range that is not in use. When clicked, opens the IP Address dialog box in which you enter the IP Address info.

Scope Toolbar

BUTTON

NAME

DESCRIPTION

Edit

Allow you to edit the selected host by opening the IP Address dialog box. Refer to DHCP Scopes.

Delete

Deletes the currently selected IP Address. Refer to DHCP Scopes.

Claim/Release

Use this feature to prevent accidental assignment of a reserved address without creating a DNS entry for it. The workflow is as follows:

  • A user with "edit data" privileges can select one or more addresses that have no associated A record(s) and choose "Claim" from the menu. Going forward, no one can create A records for the address(es) through the zone window (neither auto-assign nor manually assign).
  • A user can select one or more claimed addresses and select "Release." These addresses are then restored to their previous state.
  • A user can edit a Claimed record through the IPAM module. When the user opens a IP Address details window for a claimed address, a dialog prompts, "This address has been claimed. Are you sure you want to edit it?" Yes/No?. When Save is selected in the IP Address details window, one of two things happens: (1) If the user only entered non-DNS data (custom properties, MAC address, name), the "claimed" flag says in place.(2) If the user entered one or more DNS hosts for the IP Address, the "claimed" flag is cleared.

Quick Filter

Quick Filters provide a simple way to filter out data records you do not want to see. They can be found in most windows that contain a number of objects. A Quick Filter works in real time and searches all items in a list by default. It is also possible to narrow the search by using keywords to specify in which field to search.

Using Keywords

  • Column Headers. It is possible to use column headers as keywords in the Quick Filter and to specify in which field to search. For example, if you enter the following filtering criterion when filtering zones - name:myzone - the filter only searches in the Name field and displays only those results that contain the text myzone. When a column header's name contains a space, such as "Lease MAC Address", you can enclose the name in quotes –e.g., "Lease MAC Address":11. See Colons, below.
  • Colons. Colons are used to separate a column name from a filter. If the filter contains colons, you can either enclose the filter in quotes or escape the colons with a backslash (). For example, both "Lease MAC Address":"11:22" and "Lease MAC Address":11\:22 search for a MAC address containing "11:22" in a column with a name containing with the name "Lease MAC Address".
  • Simultaneous Keywords. You can use several keywords simultaneously simply by leaving a space between each consecutive filtering criterion. An 'AND' condition is used when finding records. For example: name:myzone type:slave.
  • Custom Properties. When custom properties are used, you can use the name of the custom property as a keyword.

Using Wildcards and Regular Expressions in Filters

When using the Quick Filters, it is possible to use the wildcard characters '^' and '$' to narrow the search results.

  • The caret symbol ^ means starts with. For example, the search string ^server finds server1.zone.com and server-north.anotherzone.com, but not myserver.myzone.com.
  • The dollar symbol $ means ends with. For example, the search string 'server$' finds the.best.server and good.nameserver, but not slow.servers.
    *The '!' operator.* You can use the '!' operator to further narrow the search results. The *exclamation mark !* means *NOT{*}.

    For example, the search string '!^a' finds entries that don't start with 'a'. The exclamation mark can be used with the other wildcards to find non-empty fields.
    Entering 'Description: !^$' finds all entries where the Description field is not empty.

    Icon

    The & and | operators only work for the SOAP interface and Web interface, but not currently for the Management Console. It is a known issue that will be fixed in an upcoming version.

  • The '&' and '|' operators. The ampersand is interpreted as an AND operator while the vertical bar is used as an OR operator. Using these operators, you can combine searches for added control. You can use parenthesis in conjunction with these operators. Examples:
    • A | B Finds entries with the text A or the text B
    • A & B Find entries containing both A and B
    • A & (B | C) Finds entries containing A and either B or C
    • (A & B) | C Finds entries containing both A and B or entries containing C
  • For even more control, you can use regular expressions in filters.
    NOTE : The character '.' must be escaped if it is to be used as a wildcard character. Otherwise, it will be interpreted literally. The same applies to following characters: ( ) { }.

Clearing an Entry

At any time, you can clear the text you have in the Quick Filter field by click the "X" shown at the end of the field.
 

Saving a Filter

It is possible to save filters for various object types. Saved filters appear in the list on the left hand side of the Manager Window and in the Create Zone dialog box. Filters can be local or global in scope. Filters created by the Administrator are global and visible to all users. Filters created by any other user are visible only to that user. 
To save a filter, do the following:

  1. Type the entry you want to filter by in the Quick Filter field.
  2. Move to the menu bar, and select Edit, Save Filter.
  3. In the dialog box, type the desired name for the filter. Then click OK.
  4. The saved filter shows at the bottom of the Object list for the corresponding object type.

Note that you can also create filters that reside in object folders. To create a filter in a folder, start by selecting the folder before creating the filter. A filter that resides in a folders perform the search within the context of the folder.

Editing a Filter

To edit a filter, do the following:

  1. Locate the filter name in the Object list.
  2. Right-click the filter and select Edit Filter.
     
  3. Make the desired changes to the filter and click OK to save the changes.

Deleting a Filter

To delete a filter, do the following:

  1. Locate the filter name in the Object list.
  2. Right-click the filter and select Delete Filter.

Jump to Box

The Jump to Box is a field that can be used to quickly open a single object in the Men & Mice Suite by entering the object name. Using the Jump to Box you can open the following object types:

  • DNS Zone
  • DNS Record
  • IP Address Range
  • DHCP Scope
  • IP Address in an IP Address Range or a DHCP Scope

The Jump to Box is located at the bottom of the sidebar on the left. Additionally the shortcut Shift-J can be used to move the focus to the Jump to Box. 

To use the Jump to Box, do the following:

  1. Navigate to the Jump to Box or press Ctrl+J
  2. Enter the name of the object you want to open and click the Jump to icon to the right of the field (or press Enter). If more than one matching object is found, a dialog box displays in which you can select the object instance you want to open.

NOTE:  You must enter the exact name of the object you want to open. For example, if you want to open a zone by the name myzone.local, it is not sufficient to enter just 'myzone' or 'myzone.lo' – you must enter 'myzone.local'. The same applies for DNS records, IP Address Ranges, DHCP Scopes and IP Addresses.

Program Preferences

You can set some default behaviors for the Men & Mice Management Console using the Options dialog box.

  • On the menu bar, select Edit, Preferences. The Options dialog box displays.
     

Log Window

  • Initial log size. The server logs are kept by the servers. When the Management Console connects to a server and the log window is opened, the Manager downloads the most recent portions of the server's log. The amount downloaded (in kilobytes) will be equal to the value set in the Initial log size field.
  • Max log size. The maximum log size determines how much of a server's log can be retained by the Management Console at any one time. Once the maximum size is reached, the Manager will discard old log entries as necessary to make room for the new ones. Log entries discarded by the Manager Console are retained on the log that the server maintains. The Max log size field can be set to any value between 1 and 1024 KBs. The default value is 100 KB.
  • Log interval. Whenever the log window is open, it will continually update itself (the log) from the server. The interval between sequential updates can be set to any value between one and thirty seconds. The default value is every five seconds.

New Zone Window

  • Show TTL. This checkbox is enabled by default. If you clear this checkbox, the TTL column will not be included in any new zones that you create.
  • Show comment. This checkbox is enabled by default. If you clear this checkbox, the Comment column will not be included in any new zones that you create.

Console

You can configure how the Console Window behaves when new entries are added to the window.

  • Do nothing. If this option is selected, entries are added 'silently' to the console window. If the window is hidden, it is not displayed when new entries are added.
  • Display Console if hidden. If this option is selected, the console window will be displayed when new entries are added.
  • Bring Console to front. If this option is selected, the console window will be displayed as the front-most window when new entries are added.

Search/Update Wizard

This utility allows you to find, create, modify, or delete records in multiple zones and DHCP Scopes using a single action. 
There are three search options available:

  • DNS Resource RecordsRefer to DNS Resource Records for further information.
  • DCHP Scope Options. Through this function, you replace, delete or search for option values.
  • IP Addresses. Through this function, you can find an IP Address in any IP Address range and display the results in the IP Address range window.

To launch the Search and Update Wizard, do the following:

  1. From the menu bar, select Query, Search and Update Wizard. The Search and Update Wizard dialog box displays.
  2. Select the type of search you want to perform.
  3. Complete each screen as you move through the wizard.
     

Lease History

Through this function, you view the lease history for your MS and ISC DHCP servers.

Icon
  • You must be a member of the DHCP Administrator group to view the DHCP lease history.
  • Lease history collection must be enabled for this function to work.

To view the DHCP lease history:

  1. From the menu bar, select Query, Lease History. The Lease History Query tab displays.
     
  2. Find DHCP leases where. Select if you want to query by IP Address, MAC Address, Server Address, Hostname or Description.
  3. Starting on/Ending on. To query based upon a date range, type the starting and ending range dates. For example, to find all changes made in 2007, in the Starting on field type 1/1/2007 and in the Ending on field, type 12/31/07. For example, to find all changes made in 2007, in the Starting on field type 1/1/2007 and in the Ending on field, type 12/31/07.
  4. Click Search. Any matching results are displayed in the lower portion of the window.

Exporting Search Results

To export the results as a CSV file, do the following:

  1. Display the lease history.
  2. Search for the desired history.
  3. When the applicable change history is shown, click the Export button. The Export records to CSV file dialog box displays.
     
  4. Select the drive, directory, subdirectory, etc. into which you want to save the CSV file.
  5. Click Save.

Object Change History

Through this function, you can display a log of all changes that have been made to any object such as the date and time of the change, the name of the user who made it, the actions performed, and any comments entered by the user.
There are two ways to search/view the object change history:

  • From the Menu Bar. With this option, you select the type of object to search change history for.
  • Through the Object Browser. With this option, you select the object first, and then search for the change history.

Accessing via the Menu Bar

  1. From the menu bar, select Query, Object History. The History Query tab displays.
     
  2. Where text contains. Type any words that the text contains.
  3. Made by. Type the user login name.
  4. Starting on/Ending on. To query based upon a date range, type the starting and ending range dates. For example, to find all changes made in 2007, in the Starting on field type 1/1/2007 and in the Ending on field, type 12/31/07. For example, to find all changes made in 2007, in the Starting on field type 1/1/2007 and in the Ending on field, type 12/31/07.
  5. Only show objects of type. Click the drop-down list arrow, and select the type of object for which you want to find change history.
  6. Limit to ____ Results. Enter the maximum number of results to display.
  7. Click Search. Any matching results are displayed in the lower portion of the tab. 
     

Accessing via the Object Browser

  1. In the Object Browser, open the desired object category (e.g., DNS Zones, DNS Servers, etc.).
  2. Locate the object for which you want to view the history.
  3. Right-click and, from the shortcut menu, select View History.
     
    The History window displays showing all the history for the selected object.

     
  4. If you wish to query the results, click the plus sign (plus)  in the upper left corner of the dialog box.
  5. Following the directions under Accessing via the Menu Bar to enter the query information.

Exporting Search Results

To export the results as a CSV file, do the following:

  1. Display the object change history.
  2. Display the Query Change History search criteria fields.
  3. Search for the desired change history.
  4. When the applicable change history is shown, click the Export button. The Export records to CSV file dialog box displays.
     
  5. Select the drive, directory, subdirectory, etc. into which you want to save the CSV file.
  6. Click Save.

Men and Mice Suite Log

Through this function, you can display log messages generated by the Men & Mice Suite.

Icon
You must be a member of an Administrator group to view the log messages.

To view the log messages, do the following:

  1. In the main Men & Mice window, move to the menu bar and select Query, Men & Mice Suite Log. The Men & Mice Suite Log tab displays.
  2. Search For. Type the information to query.
  3. Starting on/Ending on. To query based upon a date range, type the starting and ending range dates. For example, to find all changes made in 2007, in the Starting on field type 1/1/2007 and in the Ending on field, type 12/31/07.
  4. Log level. Click the drop-down list, and select the desired level – e.g., ErrorNotice or Warning.
  5. When all selections/entries are made, click Search. Any matching results are displayed in the lower portion of the window.
  6. Quick Filter. Allows you to further refine the search results. As you type in the field, results that are not applicable are removed.
  7. To export the results as a CSV file, do the following:
    • Click the Export button. The Export records to CSV file dialog box displays.
    • Select the drive, directory, subdirectory, etc. into which you want to save the CSV file.
    • Click Save.

Object Folders

To help in organizing your IP Address ranges, DNS Zones, and DHCP scopes, you can create folders and subfolders into which you can place one or more objects. You can also rename and delete folders, as well as specify access to ranges within the folder (once objects have been moved into it).

Creating a New Folder

Icon
When you create a new folder, you can move objects from the "master" list into this new folder. However, the objects always remain in the master list as well.

To create a folder, do the following:

  1. In the Object List, right-click on either IP Address ranges, DNS Zones, or DHCP scopes.
  2. From the shortcut menu, select New folder. The Create Folder dialog box displays.
     
  3. Type a name for the folder.
  4. Click OK. The new folder now displays in the Object List.
  5. To move an object into this new folder, simply highlight it and drag and drop it into this folder.

Creating a Subfolder

If desired, you can add a subfolder underneath any existing folder. 

 

Icon

If you move an object from another folder into a subfolder, the object no longer appears in the original folder. This is not the case, however, when you move an object from the master list. The object always remains in the master list, regardless of what folder/subfolder a copy is moved to.

 

In the Object List, click the plus (plus) sign next to the object type where you want to create the subfolder. The object expands to show any currently defined folders.

  1. Right-click on the folder to which you want to add a subfolder.
  2. From the shortcut menu, select New Folder.
  3. In the Create Folder dialog box, type a name for the new subfolder.
  4. Click OK. You can now move objects into this subfolder by dragging/dropping them from the list on the right.

Renaming a Folder

You can rename any folder by doing the following:

  1. Select the folder you want to rename.
  2. Right-click and, from the shortcut menu, select Rename.
  3. In the Rename folder dialog box, type the new name for the folder.
  4. Click OK. The object list refreshes and the new folder name displays.

Specifying Access for Folder Items

Once you have created a folder and moved objects into the folder, you can assign permissions to the ranges in the folder to control who can work with those objects.
Choosing access for a folder does not set the access for the folder, but merely selects all objects in the folder and applies the access settings to these objects.
To specify access for item/items in a folder, do the following:

  1. Right-click on the folder and, from the shortcut menu, select Access.
  2. In the Access Control dialog box, select the group/user (or add a new group/user). Then, specify the permissions for the user.
  3. Click OK.
  4. If desired, enter a Save Comment when prompted.

Deleting a Folder

When deleting a folder, the objects within the folder are not deleted and remain intact.
To delete a folder/subfolder, do the following:

  1. Right-click on the folder and, from the shortcut menu, select Delete.
  2. When the confirmation message displays, click Yes.

Health Monitoring Bar

Overview

The Men & Mice Health Monitoring provides the administrator with valuable information he needs to maintain his systems and services. First, a good overview of the general health of the Men & Mice Suite and related services. More importantly, it will give the administrator an indication if there is a problem that needs to be acted on and corrected, for example if there is a slave zone that is expiring or if there is a zone that has not been loaded on a server due to an error. Both cases can cause outages for users and therefore be a serious impact for the business.

Categories

The health status is displayed to the user from the health bar which is positioned at the bottom of the management console window. The status indicators are split into five categories
  • Men & Mice Suite
  • DNS
  • DHCP
  • IPAM
  • Appliance

A color code is used to represent the severity of the error. If an indicator in any of those categories has a warning or error, it is shown as yellow or red, respectively; otherwise as green. The health bar can be expanded and then the indicator subcategories are shown and more details can be obtained about the health indicators. More importantly, details about each error are given in a separate window where a detailed description about the error is given and also the administrator is given the opportunity to navigate to the object that is affected and from there, fix the error.
In the figure above, the health bar has been expanded by clicking the up arrow in the upper right corner of the health bar. There, it can be seen the there are errors in 'DNS Zones' and 'Server Controllers' and a warning in 'Version'. 

Indicator details

CategorySubcategoryDescription
Men & Mice Suite  
 LicensingAn indication is given if there is a problem with the licence, for example if a module licence has been exceeded.
 DatabaseAn indication is given if the database size exceeds a default threshold of 1GB for SQLite.
 Server Controllers
An indication is given if
  • the server controllers have a problem communicating with men & mice central
  • there is a problem communicating with the update agents running beside the server controllers. 
 VersionAn indication is given if there is a new version available, if there are pending upgrades or if any components are out of date. 
DNS  
 DNS ServersAn indication is given if there is a problem communicating with the servers or if the DNS server is down
 DNS Zones
An indication is given if
  • the system is unable to get the zone status
  • the slave zone will expire in the next 24 hours
  • the zone can not load on the server
DHCP  
 DHCP ServersAn indication is given if there is a problem communicating with the servers or if the DHCP server is down
 DHCP Scopes
An indication is given if
  • the system is unable to get the scope status
  • the static part of scope is over utilized
  • the dynamic part of scope is over utilized
  • a superscope is over utilized
  • there is a s cope pool collision
  • there is a scope reservation mismatch
  • scope contains inconsistencies that need reconciling
  • the system is unable to check whether scope contains inconsistencies
  • the system is unable to check whether scope is part of a failover relationship on partner server
  • the DHCP failover partner server is unreachable
  • the system is unable to fetch scope info from the partner server
  • if a scope is not part of a failover relationship on the partner server
IPAM  
 Static
An indication is given if a subnet is over utilized
 DiscoveryAn indication is given if there are problems with communicating with routers
Appliance  
 Appliance healthAn indication is given if an appliance is unreachable

 

In any case of an warning or error above, there will be a detailed description of the error or warning, and a way to navigate to the proper place to fix an error/warning.  

Ignoring indicators

By right clicking a status indicator in the health bar and selecting 'ignore', that status indicator can be ignored.

Viewing error / warning indicators

 

In this window more details about the status indicator can be seen. Following are descriptions about what each column shows.

  • Message: Details about the error / warning for this indicator
  • Object: Name of the object that the error / warning is related to
  • First seen: The date of which the error / warning was first seen

 

In the figure below, we have clicked on the 'Discovery' indicator to get more details about the error.  

Right clicking an indicator will show a context menu with the following items (where applicable):

  • Show in manager window: Show the specific item in the manager window
  • Open: Opens a specific object, for example a scope
  • Reconnect: Reconnects to an already disconnected server

Disabling health monitoring

The system health monitoring can be disabled completely by setting an advanced system option. See Advanced System Settings for more details. 

  • No labels